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1. Abbreviations 

ROI: Region of interest 

LUT: Look-up table 

Stack: Data structure with a set of related images of the same size and bit depth. 

Slices: The images that make up a stack. 

Hyperstack: Multidimensional data structure, extending image stacks to four (4D) or five (5D) 
dimensions: x (width), y (height), z (slices), c (channels or wavelengths) and t (time frames). 

Voxel: In stacks, a pixel (which represents the smallest 2D image data) becomes a voxel (volumetric 
pixel), i.e. an intensity value on a regular grid in a three dimensional space. 

2. Remarks 

This script was written for practical training purposes by the Center for Microscopy and Image Analysis, 
University of Zurich. Theory is kept to a minimum.  

Images - Center for Microscopy, ZMB; Sample courtesy - Prof. Bruno Weber, Inst. Of Pharmacology, 
UZH and Prof. Andrew Hall, Inst. Of Anatomy, UZH 

The script should be used as a guideline for training. 

Highlighting styles used in this script: 

File names are set in green (e.g. Cell_Division_Pinhole_0_5AU_Nyquist_7386.lif) 

  
Practical steps are set in italic. Keyboard shortcurts here 

Macro code:  run("Enhance Contrast", "saturated=0.35"); 
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3. Software: FiJi  

This script gives a basic introduction to scientific image processing. All exercises can be done using 
ImageJ or Fiji which is just a version of ImageJ supplemented with many useful plugins. It can be 
downloaded for free from 

https://fiji.sc/ 

Downloadable distributions are available for Windows, Mac OS X and Linux. It 
can read many image and microscope formats including TIFF, GIF, JPEG, BMP, 
DICOM, FITS, IMS, LIF, CZI, ‘raw’.  

Install your own copy of FiJi and selected plugins in your home folder if you 
are using the virtual machines available to the users of the Center of 
Microscopy and Image Analysis. Otherwise save it locally in your computer.  

4. Plugins and Updating 

When installing FiJi from the Downloads page, the latest stable version is available. However FiJi and 
its various plugins are frequently updated so you should check if you have the latest updates through 

  
Help>Update 

Here you can also manage the update sites and install additional useful plugins which are not installed 
by default.  

5. Opening Standard File types 

 

Files can be opened in two ways, Drag&Drop the file in the task bar OR through  

 File>Open 

For some file formats, you may want to explicitly invoke the Bio-Formats Importer to override the 
default behavior of Fiji. Bio-Formats is largely integrated with the File/Open command of Fiji but might 
be useful for certain formats and also gives you some advanced options. 

 File>Import>Bio-Formats 

You can find an updated list of the supported file formats here: 

https://www.openmicroscopy.org/bio-formats/ 

https://fiji.sc/
https://www.openmicroscopy.org/bio-formats/
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6. The command Finder 

ImageJ has many features and sometimes it can be hard to find and keep track of all of them. In Fiji 
version 1.51 and higher, you can type your search term in to the white box at the end of the taskbar 
and a new window will pop up with your search results 

 

7. Digital Image – representation  

Please check if Fiji is configured as follows: 

 Edit>Options>Appearance:  
 
Please uncheck the 'Interpolate zoomed images' 

This allows you to see the individual pixels on the screen when zooming images. 
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8. Metadata & Image Info 

 Open the file “Hyena.tif” contained in the folder provided for this training session.  
 Magnify the image until pixels are seen ( , press Alt  to demagnify). 
 Individual pixel values can be visualized by placing the cursor over pixels. 

 

Once you open an image or stack of images, 
notice the information at the top of the image 
window.   

1. The top line contains the name of the 
image.  
2. “900x631 pixels” is the image size. The 
units depend on how the image is calibrated. In 
this case, the units are pixels indicating the 
image is NOT calibrated. 
3. The memory your image takes up on 
the hard drive. 

 Open the files “Hyena02.tif” and 
“Hyena03.tif”. 

 

What is the size of each image? How many pixels are necessary for resolving the animal?  

In scientific imaging the pixel size will depend on the microscope you are using and the magnification 
factor (camera, objective plus any zoom applied during imaging). This information (metadata) can be 
embedded in the image file or is sometimes found in a text or log file that is generated by the 
microscope software along with the image and is accessible by Fiji.  

 Open the file “Cells_DIC.tif”.  

 

Note that in this case the image is 
calibrated and the units shown 
are in µm.  

Size, area, distance, etc. measurements made on a calibrated image will be given in units matching the 
unit of length you entered. Uncalibrated images give measurements in pixels. 
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Some of the information contained in the image metadata can be accessed through 

  
Image>Properties or  Ctrl+Shift+ P 
Image>Show Info Ctrl+I 

 

Based on this information you can also include a scale bar in your image through the menu 

  
Analyze> Tools > Scale Bar  

 

Unclick Overlay if you want these change to be permanent and embed the scale bar into the image. 
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9. Duplicate 

You can create a copy of your image by 

  
Image>Duplicate  Ctrl+Shift+ D 

This is a standard procedure, especially if 
you wish to compare your processed image 
to the original. The Undo option is not 
applicable to some of the processing 
options and this ensures that you can easily 
revert your steps without opening the 
source file again. 

It can also be used to create a new image 
from a selection.  

If you wish to revert to your originally saved 
image you can also use the command 

File>Revert  Ctrl+ R 

10. Brightness and Contrast - Dynamic Range 

  
Select Image>Adjust>Brightness/Contrast  Ctrl+ Shift+C 

You can adjust the slider 'minimum, 
maximum, brightness, contrast'.  

“Minimum” or maximum set either the 
bottom or the top of the display range.  

 “Brightness” adjusts both the top and 
bottom brightness values displayed 
without changing the size of the range 
displayed while the “Contrast” 
increases or decreases the size of the 
displayed range.  

 “Auto” button chooses the best 
display range, by saturating 0.35% of 
the pixels in your image.  

The “Reset” button resets the image to its original (full) display range.  

You can also use “Set” to type in values for the top and bottom of the display range.   

Make sure you avoid saturated pixels and clipping.  
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None of these changes affect pixel intensity values UNLESS you press the “Apply” button. This will 
compress the intensity distribution of your image. Usually there is no need to use this option and it 
should not be used when you want to quantify or compare images. 

 S
elect Analyze>Histogram  

Activate the Live button and change your brightness and contrast settings. When you hit “Apply” this 
changes will alter the histogram of your image. 

 S
elect Process>Math>Gamma and adjust the image with different gamma values.  

11. Pseudocoloring Images 

Look up tables (LUTs) are fundamental in highlighting the desired features of an image. The human eye 
can only perceive relatively few different shades in one scene. Therefore pseudo-colouring images can 
make the data more insightful.  

 S
elect Image>Lookup tables and use different LUTs. Any image can be used (e.g. 
Mitochondria_DIC_ch1.tif or kidney.tif for a time series.) 

 

If you wish to export the image so the color information is available in other programs, choose  

  
Image >Type> RGB Color.  

You may also include a scale bar, which can be added to the RGB image, as illustrated in 9. If you want 
to visually relate your LUT to the image intensity values, you can also include a calibration bar 

  
Analyze>Tools>Calibration Bar 
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12. Stacks  

  
Open the files Mitochondria_DIC_ch1.tif and Mitochondria_DIC_ch2.tif 

 

Often we acquire images with multiple spectral channels (multi colors). These images might be 
saved individually as grayscale files but you can easily merge them into stacks and visualize them 
as multi-color images. 

  
Image>Color>Merge Channels 

These files need to have the same physical size, the same number of slices per stack and have the 
same image type (in this example 1128x1128 pixels, 1 time point and 16-bits). You can also use 
this command if you have additional dimensions such as time series or z stacks. 

“Create Composite” creates a stack while maintaining the image type. If you unclick this option an RGB 
file will be created instead. “Ignore source LUTs” can be used if you want to apply a different color in 
the merge than the original LUTs. Alternatively you can also explore  

  
Image>Color>Channel Tool Ctrl+ Shift+C 
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13. Hyperstacks 

Additionally you might encounter multidimensional files such as time series or z stacks with different 
channels. These can be saved in various ways and can sometimes be challenging to visualize in a single 
stack. By creating a Hyperstack you will be able to better handle and visualize such data.  

  
Open the file “Mouse_Brain_stack.tif  

 

This file contains a 2 color set with multiple planes, but is displayed as a single stack with 102 slices. To 
create a Hyperstack go to 

  
Image> Hyperstacks>Stack to Hyperstacks 

You can determine the order of your stack by running through it and looking at what changes first. For 
example: if your images flip between colors, then the z-plane changes, you have a stack with the 
default xyczt dimensions. Fill in the number of channels, slices and frames accordingly. 

Check that the numbers for channels, slices and frames fit your dataset. If your numbers are not correct 
ImageJ will not render and will give you an error message. 

14. Reduce dimensionality 

Conversely you might only need to work on a subset of your hyperstack. You can do this through  

  
Image> Hyperstacks>Reduce Dimensionality  

Or 

Image> Stacks>Tools>Make Substack  

Create a stack containing only the second channel for the following section. 

This approach can be also very useful when you want to easily extract a specific 
channel or time point from a 4D or 5D dataset and resave it with a new filename. 
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15.  Projections and 3D 

 

Z projections compress multiple slices/planes (3D volume) into one plane (2D image) to “flatten” 
a stack and therefore allowing better representation on a 2D medium such as a screen or paper. 
One of the most commonly used is the maximum intensity projection, which finds the brightest 
pixel in the stack for each XY position and projects those into a single XY plane. You can achieve 
this and explore the multiple projection options in 

  
Image>Stacks>Z Project 

 

  
Try to make a 3D projection along different viewing axes to simulate a rotation of the image 
for presentation purposes: Image>Stack>3D Project (-30 to +30° works normally ok). Select 
different settings. 

16. Particle counting and measuring 

Image segmentation and quantification is the 
most important and also the most often 
performed image processing task. Automatic 
counting and quantification plays a crucial role 
in many applications including high content 
imaging and screening. 

Manually selecting a region of interest (ROI) 
and measuring variables such as size, shape and 
intensity is one possible way.  

In ImageJ you can manually define ROIs using 
the different tools from the main software 
interface such as: “Rectangle”, “Oval”, 

“Polygon selection”, etc..  

To handle multiple selections in parallel you can add them to the ROI Manager through 
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Edit>Selection>Add to Manager T 

You can then extract the information contained in each individual ROI using the 
option Multi-Measure in the ROI Manager. 

To measure a single selected ROI use 

  
Analyze>Measure M 

Automatic segmentation of images has the advantage of allowing for quantification 
a larger numbers of objects while reducing bias. Here we count bacteria on an 
electron micrograph using intensity thresholding  and an eroding/dilating algorithm 
on the binary image. 

 

  
1. . Open the image Bacteria.tif. 
2. Duplicated the image using Image>Duplicate 
3. Select Image>Adjust>Threshold to select the object (move the slide bars so that the objects are 

be in red).  
4. Apply the selection.  
5. Using Process>Binary>Fill Holes, none selected areas inside an object are filled.  
6. Using Process>Binary>Open (or Erode/Dilate) touching structures can be separated until an 

acceptable selection of the objects is achieved.  
7. Using Analyze>Analyze Particles all objects are measured (e.g. area, size,…) automatically. 

If you want to select what aspects of your segmentation should be measured and exported, you can 
define this under 

  
Analyze>Set Measurements 

This menu also allows you to “redirect” your measurement and therefore as an example to measure 
the intensity values in your source and not in the binary segmented file. 
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17. Saving and Image file formats  

  
1. Open the image “baboon.tif” 
2. Save the image as a jpg file through File> Save as. 
3. Open the saved jpg file and compare the original tif file with the jpg copy (zoom to see the 

pixels in both images)! 

The JPEG image format uses a lossy compression that leads to image artifacts that are not compatible 
with quantitative analysis. As such, it should only be used for presentation purposes (where file size 
can be an issue). Even then a lossless format such as PNG is probably more suitable.  

To visualize the loss of information in such a compression you can subtract both images through 

  
Process>Image Calculator 

Adjust Brightness and Contrast accordingly.  

TIFF is usually the format of choice that supports all ImageJ data types (8-bit, 16-bit, 32-bit float and 
RGB) and allowing for spatial and density calibration.  

 

18. Literature and further information 

• The ImageJ online documentation 

o can be accessed via Help>Documentation... 

• The ImageJ Information and Documentation Portal (ImageJ wiki): 

o  http://imagejdocu.tudor.lu/  

• Several online documents, most of them listed at: 

o http://rsb.info.nih.gov/ij/links.html 

• Forum for multiple image processing softwares 

o https://forum.image.sc/ 

 

 

http://imagejdocu.tudor.lu/
http://rsb.info.nih.gov/ij/links.html
https://forum.image.sc/
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